Reply To: いくつかのプラグインがkusanagi9で利用できない

TOP Forums 使い方全般(Fixing KUSANAGI) いくつかのプラグインがkusanagi9で利用できない Reply To: いくつかのプラグインがkusanagi9で利用できない

#764
katakura
Participant

    こんにちは、masahiroさん。

    起きた現象を確認したいと思いますので、以下の情報を教えてください。
    ・PHPのバージョン
    ・KUSANAGIのバージョン
    ・利用しているWebサーバーエンジン(nginx or httpd)
    ・WordPressのバージョン
    ・プラグイン名とそのバージョン
    ・利用しているテンプレート名
    ・/home/kusanagi/(プロファイル名)/log/(利用しているWebサーバーエンジン)/配下の ssl_error.log ファイルと error.log ファイルの内容

    もし、PHPのバージョンが8であれば、ftpsocketに問題がありftpが動作しない現象が確認されています。
    pluginのインストールやテーマの更新などは、ftpを経由するのでこれが原因の可能性が高いです。
    PHPのバージョンが8であれば、以下の方法で解決できます。

    ・KUSANAGIのPHPのバージョンを7.4に落とす
     コマンドは kusanagi php --use php74 です。

    ・wp-config.phpを編集する
     wp-config.php内の以下の記載

    define(‘FS_METHOD’, ‘ftpsockets’);

     を

    define(‘FS_METHOD’, ‘ftpext’);

     か

    define(‘FS_METHOD’, ‘ssh2’);

     に変更します。

    • This reply was modified 2 years, 3 months ago by katakura.