TOP Forums バグ報告と提案(Requests and Feedback) モジュールアップデート時の依存関係エラー

This topic contains 4 replies, has 3 voices, and was last updated by  hillbook 4 months, 1 week ago.

  • Author
    Posts
  • #621

    hillbook
    Participant

    yum updateでパッケージアップデートを試みたところ、依存関係のエラーが出力されました。
    「–skip-broken」しても良いのでしょうか。

    –> 依存性の処理をしています: libonig.so.2()(64bit) のパッケージ: kusanagi-hhvm-3.19.1-1.noarch
    –> 依存性解決を終了しました。
    エラー: パッケージ: kusanagi-hhvm-3.19.1-1.noarch (@kusanagi)
    要求: libonig.so.2()(64bit)
    削除中: oniguruma-5.9.5-3.el7.x86_64 (@epel)
    libonig.so.2()(64bit)
    次のものにより更新された: : oniguruma-6.8.2-1.el7.x86_64 (epel)
    ~libonig.so.5()(64bit)
    問題を回避するために –skip-broken を用いることができます。
    これらを試行できます: rpm -Va –nofiles –nodigest

    参考情報)

    環境:さくらのVPS(kusanagi)
    OS:CentOS Linux release 7.8.2003 (Core)

    # kusanagi status
    Profile: html
    FQDN: i-think-it.net
    Type: WordPress
    KUSANAGI Version 8.4.5-6
    sakura

    *** (active) nginx ***
    ● nginx.service – The NGINX HTTP and reverse proxy server
    Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled; vendor preset: disabled)
    Active: active (running) since 土 2020-06-13 14:45:42 JST; 5 days ago

    *** (active) php7-fpm ***
    ● php7-fpm.service – The PHP FastCGI Process Manager
    Loaded: loaded (/usr/lib/systemd/system/php7-fpm.service; enabled; vendor preset: disabled)
    Active: active (running) since 土 2020-06-13 14:45:42 JST; 5 days ago

    *** (active) MariaDB ***
    ● mariadb.service – MariaDB 10.1.45 database server
    Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
    Active: active (running) since 日 2020-05-24 19:03:21 JST; 3 weeks 4 days ago

    *** ruby ***
    ruby 2.4.6p354 (2019-04-01 revision 67394) [x86_64-linux]

    *** add-on ***

    *** Cache Status ***
    bcache off
    fcache on

    *** WAF ***
    off

    *** SELinux ***
    off (permanent)

    完了しました。

  • #622

    hideishi
    Participant

    epelのonigurumaが更新された影響ですね。
    今すぐkusanagiのアップデートが必要な場合は、以下のコマンドで回避してみてください。
    `yum update –exclude=oniguruma
    他にonigurumaに依存してエラーが出るものがあったら、それもカンマ区切りでexcludeに追加してください。

    • #623

      hillbook
      Participant

      回答ありがとうございます!
      onigurumaが更新された影響なのですね。
      しばらく様子見し、必要であればexcludeしてkusanagiアップデートしたいと思います。

  • #624

    hagemarugt
    Participant

    自分も本日updateしたら全く同じ症状の

    エラー: パッケージ: kusanagi-hhvm-3.19.1-1.noarch (@kusanagi)

    だったので、とても参考になりました。ありがとうございました。
    自分もしばらく様子見させていただきます。

    • #625

      hillbook
      Participant

      昨日試したら、モジュールエラーが解消されていて普通にアップデート出来ました。
      試してみてください。

You must be logged in to reply to this topic.