dnf updateにてパッケージ競合のエラーが発生

TOP Forums バグ報告と提案(Requests and Feedback) dnf updateにてパッケージ競合のエラーが発生

dnf updateにてパッケージ競合のエラーが発生

Tagged: 

Viewing 4 reply threads
  • Author
    Posts
    • #1225
      yoshi
      Participant

        お世話になります。

        サーバー上でdnf updateを試みた際に、特定のパッケージの更新についてエラーメッセージが表示される問題に直面しています。「–allowerasing」、「–skip-broken」、「–nobest」などののオプションを試せばいいのでしょうか?

        以下にエラーメッセージの詳細を示します:

        
        Last metadata expiration check: 0:09:07 ago on Wed 26 Jul 2023 12:36:49 AM EDT.
        Error:
         Problem 1: package kusanagi-libcurl-8.1.2-1.el9.x86_64 from @System requires libnghttp3.so.6()(64bit), but none of the providers can be installed
          - cannot install both kusanagi-nghttp3-0.13.0-0.el9.x86_64 from kusanagi and kusanagi-nghttp3-0.11.0-0.el9.x86_64 from @System
          - cannot install both kusanagi-nghttp3-0.13.0-0.el9.x86_64 from kusanagi and kusanagi-nghttp3-0.11.0-0.el9.x86_64 from kusanagi
          - cannot install the best update candidate for package kusanagi-nghttp3-0.11.0-0.el9.x86_64
          - cannot install the best update candidate for package kusanagi-libcurl-8.1.2-1.el9.x86_64
         Problem 2: problem with installed package kusanagi-libcurl-8.1.2-1.el9.x86_64
          - package kusanagi-libcurl-8.1.2-1.el9.x86_64 from @System requires libngtcp2.so.12()(64bit), but none of the providers can be installed
          - package kusanagi-libcurl-8.1.2-1.el9.x86_64 from @System requires libngtcp2_crypto_openssl.so.4()(64bit), but none of the providers can be installed
          - package kusanagi-libcurl-8.1.2-1.el9.x86_64 from kusanagi requires libngtcp2.so.12()(64bit), but none of the providers can be installed
          - package kusanagi-libcurl-8.1.2-1.el9.x86_64 from kusanagi requires libngtcp2_crypto_openssl.so.4()(64bit), but none of the providers can be installed
          - cannot install both kusanagi-ngtcp2-0.17.0-1.el9.x86_64 from kusanagi and kusanagi-ngtcp2-0.15.0-1.el9.x86_64 from @System
          - cannot install both kusanagi-ngtcp2-0.17.0-1.el9.x86_64 from kusanagi and kusanagi-ngtcp2-0.15.0-0.el9.x86_64 from kusanagi
          - cannot install both kusanagi-ngtcp2-0.17.0-1.el9.x86_64 from kusanagi and kusanagi-ngtcp2-0.15.0-1.el9.x86_64 from kusanagi
          - cannot install the best update candidate for package kusanagi-ngtcp2-0.15.0-1.el9.x86_64
        (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
        

        サーバー構成(Azure)
        OS Linux (centos 9)
        サイズ Standard B2s (2 vcpu 数、4 GiB メモリ)

        # kusanagi status
        KUSANAGI Version 9.3.2-1.el9
        azure

        *** (inactive) nginx : nginx125 ***
        * nginx.service – The NGINX HTTP and reverse proxy server
        Loaded: loaded (/usr/lib/systemd/system/nginx.service; disabled; preset: disabled)
        Active: inactive (dead)

        *** (active) httpd : httpd ***
        * httpd.service – The Apache HTTP Server
        Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; preset: disabled)
        Active: active (running) since Wed 2023-07-26 00:25:27 EDT; 17min ago

        *** (active) php : php82 ***
        * php-fpm.service – The PHP FastCGI Process Manager
        Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled; preset: disabled)
        Active: active (running) since Wed 2023-07-26 00:25:27 EDT; 17min ago

        *** (active) mariadb : mariadb10.9 ***
        * mariadb.service – MariaDB 10.9.7 database server
        Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; preset: disabled)
        Active: active (running) since Tue 2023-07-04 03:29:56 EDT; 3 weeks 0 days ago

        *** (inactive) psql : ***

        *** (inactive) pgpool-II : ***

        *** python ***
        Python 3.9.17

        *** ruby ***
        ruby is not installed.

        *** Cache status ***
        bcache off
        fcache off

        *** WAF ***
        on

        *** SELinux ***
        off

        # kusanagi –version
        KUSANAGI Version 9.3.2-1.el9

        # yum check-update
        Last metadata expiration check: 0:07:51 ago on Wed 26 Jul 2023 12:36:49 AM EDT.

      • #1226
        cloudy
        Participant

          yoshi さん、こんにちは。

          dnf clean all した後に、再度 dnf upgrade を試していただけますか?

          私の環境では再現しませんでした。

          直近で 2 つの更新がリリースされているため、dnf upgrade とタイミングが悪く競合が発生しているかもしれません。

          KUSANAGI 9モジュール更新情報

          KUSANAGI 9 モジュール更新情報

          • This reply was modified 7 months ago by cloudy.
        • #1228
          cloudy
          Participant

            yoshi さん、こんにちは。

            補足です。

            dnf updatednf upgrade はどちらも同じコマンドです。
            公式では dnf upgrade の方を推奨しているようです。

            https://dnf.readthedocs.io/en/latest/cli_vs_yum.html

            ただし、yum updateyum upgrade は異なります。

            • This reply was modified 7 months ago by cloudy.
          • #1230
            cloudy
            Participant

              dnf upgrade の実行タイミングで同じような事象が起こるケースがあると思いますので、FAQ に対応方法を追記していただきました。

              KUSANAGI 9 FAQ

              FAQ

              Q4. dnfでアップデートを実行すると、エラーが出力されてアップデートできません。

            • #1231
              yoshi
              Participant

                cloudy様

                お世話になります、ご回答いただきありがとうございました。

                さきほど、dnf updateを実行したところ無事更新されました。
                実行タイミングが悪かったようですね。。。

                FAQにもご記載ありがとうございます。今度同じエラーになりましたらdnf clean allを試してみます。

                dnf upgradeの方が推奨とのこと、ご教授いただきありがとうございます。

            Viewing 4 reply threads
            • You must be logged in to reply to this topic.

            Next article

            フォーラムについて