nginx・php-fpm 再起動後にWordPressのコンテンツが表示できない

TOP Forums WEXAL® パーソナルライセンス nginx・php-fpm 再起動後にWordPressのコンテンツが表示できない

nginx・php-fpm 再起動後にWordPressのコンテンツが表示できない

Viewing 1 reply thread
  • Author
    Posts
    • #1180
      link_sugawara
      Participant

        KUSANAGI for VMware (8.5.2-2) に WEXAL (2.5.4) を適用して運用しています。

          PHP 7.3.13
          nginx 1.19.10
          MariaDB 10.1.43

        一週間ほど前に nginx と php-fpm でタイムアウトとなる時間の設定を変更後、
        これら2つのプロセスを再起動したところ、
        WordPress で構築しているコンテンツがいっさい表示されなくなってしまいました。
        以下は KUSANAGI のプロファイル配下にある log/nginx/ssl_error.log の内容です。

        [error] 20157#0: *53 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught exception 'Exception' with message 'The application requires PHP version 7.0 or higher.' in /home/kusanagi/public_html/wexal/page_speed_technology/autoload.php:3
        Stack trace:
        #0 /home/kusanagi/public_html/wexal/page_speed_technology/pst.control.php(6): require_once()
        #1 /home/kusanagi/public_html/DocumentRoot/wp-content/mu-plugins/wexal_page_speed_technology_for_wp.php(35): require_once('/home/kusanagi/...')
        #2 /home/kusanagi/public_html/DocumentRoot/wp-content/mu-plugins/wexal_page_speed_technology_for_wp.php(289): wexal_page_speed_technology_for_wp->__construct()
        #3 /home/kusanagi/public_html/DocumentRoot/wp-settings.php(291): include_once('/home/kusanagi/...')
        #4 /home/kusanagi/public_html/wp-config.php(99): require_once('/home/kusanagi/...')
        #5 /home/kusanagi/public_html/DocumentRoot/wp-load.php(42): require_once('/home/kusanagi/...')
        #6 /home/kusanagi/public_html/DocumentRoot/wp-blog-header.php(13): require_once('/home/kusanagi/...')

        PHP のバージョンは問題ないにもかかわらず、このエラーが表示される原因がわかりません。
        WEXAL の利用を止めることでエラーが表示されなくなりましたが、
        不具合を解消するためには最新版へのアップデートしかないのでしょうか。

      • #1181
        hideishi
        Participant

          WEXALはPHP7以上が必須なので、PHP5.6では動作しません。

          php-fpmサービスは PHP5.6 です。
          PHP7 は php7-fpm サービスになります。

          タイムアウト時間を変更した際に、誤って php7-fpm の代わりに php-fpm を起動したのではないでしょうか?

          KUSANAGIコマンドも kusanagi php は PHP5.6 で、PHP7 は kusanagi php7 です。
          kusanagi php7 を実行して、PHP7に戻してください。

          なお、PHP7のiniの場所はPHP5.6と異なるので、タイムアウトの設定を変更している場合は同じものを
          PHP7にも設定してください。/etcのディレクトリ名で判断できると思います。

          • This reply was modified 1 year, 3 months ago by hideishi.
      Viewing 1 reply thread
      • You must be logged in to reply to this topic.

      Next article

      フォーラムについて