TOP Forums インストール(Installing KUSANAGI) phpのダウングレード方法について

This topic contains 3 replies, has 3 voices, and was last updated by  ma-to 4 months, 2 weeks ago.

  • Author
    Posts
  • #477

    masabou
    Participant

    お世話になっております。

    現時点、KUSANAGIをインストールすると、7.3.0 でインストールされます。
    これを 7.0.23 にダウングレードする方法を教えてください。

    # yum downgrade kusanagi-php7

    では 7.2.10 までダウングレード出来ますが、それ以降はエラーとなります。

    よろしくお願いします。

  • #482

    yuki
    Participant

    既存のphpを全て削除してからバージョン指定してインストールする方法になると思います。

  • #494

    masabou
    Participant

    ありがとうございます。
    具体的にどのようなコマンドで既存のphpを全て削除、バージョン指定してインストールすれば良いかご教授いただければ幸いです。
    よろしくお願いします。

  • #495

    ma-to
    Participant

    自己責任でお願いします。

    # yum remove kusanagi*

    このような感じでしょうね。
    kusanagiと付く物は削除されます。

    自分の意図するバージョンをインストールしようとしても、依存関係でインストール出来ない場合も
    あることをご理解ください。

    今回の場合はPHPですが、Apache等の場合は依存関係で古いバージョンに戻ればい場合もありま
    す。
    何度も申し上げますが、自己責任でお願いします。

You must be logged in to reply to this topic.