PHP 7.3.14-1を対象としたyum updateに失敗する

TOP Forums インストール(Installing KUSANAGI) PHP 7.3.14-1を対象としたyum updateに失敗する

PHP 7.3.14-1を対象としたyum updateに失敗する

Viewing 2 reply threads
  • Author
    Posts
    • #579
      ohara
      Participant

      ご担当者様

      お世話になっております。

      [PHP 7.3.14-1no]というタイトルで投稿させていただいたトピックは途中で誤ってお送りしてしまったものですので
      破棄していただきたいと思います。

      表題の件につきまして、1月31日に更新された「PHP 7.3.14」のモジュールのアップデートを行うため
      yumupdateを実施したところ、以下のログが記載されyumupdateが失敗しております。
      正常にupdateを行うため、原因と解決方法を伺いたいので、ご対応をお願いします。

      下記にログと、実施したことを記載しておきますので
      宜しくお願い致します。

      ■ログ
      読み込んだプラグイン:fastestmirror\nDetermining fastest mirrors\n
      * base: ty1.mirror.newmediaexpress.com\n
      * epel: d2lzkl7pfhq30w.cloudfront.net\n
      * extras: ty1.mirror.newmediaexpress.com\n
      * updates: ty1.mirror.newmediaexpress.com\n
      依存性の解決をしています\n
      –\u003e トランザクションの確認を実行しています。\n
      —\u003e パッケージ kusanagi-php7.noarch 0:7.3.13-1 を 更新\n
      —\u003e パッケージ kusanagi-php7.noarch 0:7.3.14-1 を アップデート\n
      –\u003e 依存性の処理をしています: libwebp.so.7()(64bit) のパッケージ: kusanagi-php7-7.3.14-1.noarch\n
      –\u003e 依存性解決を終了しました。\n
      問題を回避するために –skip-broken を用いることができます。\n
      これ らを試行できます: rpm -Va –nofiles –nodigest\n\n
      ———-ERROR——-\n
      エラー: パッケージ: kusanagi-php7-7.3.14-1.noarch (kusanagi)\n
      要求: libwebp.so.7()(64bit)\n\nfailed to run commands: exit status 1

      ■実施したこと
      ・yum clean allの実施後にyumupdate実施
      ⇒エラー内容変わらず、失敗。

      ・要求: libwebp.so.7()(64bit)\n\nfailed to run commands: exit status 1
      のエラーに従い、yum install libwebp –enablerepo=remi -y
      ⇒エラー解消せず(yumではなくrpmでのパッケージインストールが必要?)

      ・yum update –skip-broken -y コマンドの実行
      ⇒正常終了したものの、PHPのモジュール自体はアップデートされていない状態と認識。

      現状、脆弱性を含有している状態と認識しておりますので、早急に対処したい次第です。
      お忙しいところ恐縮ですが、ご対応宜しくお願い致します。

    • #580
      ohara
      Participant

      ・要求: libwebp.so.7()(64bit)\n\nfailed to run commands: exit status 1
      のエラーに従い、yum install libwebp –enablerepo=remi -y
      ⇒エラー解消せず(yumではなくrpmでのパッケージインストールが必要?)

      と記載させていただいたのですが、先ほどrpmでのLibwebp.so.7のインストール後、yumupdateを実施したところ、正常に終了し、無事にphpのバージョンも上がったことを確認しました。

      今回のyumupdateは本対応で解決できたので良かったのですが、rpmでののインストールを実施しているため、暫定対応かと思います。
      Libwebp.soとphpが依存関係がある場合、phpのアップデートが行われるに合わせてLibwebp.soも都度、指定のバージョンをインストールしていく必要があるのかどうかを懸念しております。

      yumでインストールできればよかったのですがそれができなかったため、何かできる方法をご存じであれば教えていただきたいと思います。

    • #581
      hideishi
      Participant

      oharaさん

      libwebp.so.7(64bit)は以下のコマンドでインストールできます。(libwebpではなく、libwebp7です)
      yum install libwebp7 –enablerepo=remi -y

Viewing 2 reply threads
  • You must be logged in to reply to this topic.

Next article

フォーラムについて