provisionできない

TOP Forums インストール(Installing KUSANAGI) provisionできない

provisionできない

Tagged: 

Viewing 3 reply threads
  • Author
    Posts
    • #1239
      Htoyoda
      Participant

        いつもお世話になっています。

        現在、すでに1つのサイトが稼働している状況にて、追加で1つのサイトのprovisionを行いたいと思い、
        kusanagi provision –LAMP コマンドを実行しましたが、エラーとなります。
        以下、実行コマンドとエラーメッセージとなります。
        御助言頂ければ幸いです。
        なお、dnf updateは実施済みで、kusanagi最新環境となっております。

        コマンド:
        # kusanagi provision –LAMP –fqdn new.xxx.co.jp –email admin@xxx.co.jp –dbname 123 –dbuser 123 –dbpass “1234” new-site

        エラーメッセージ:
        Target directory is /home/kusanagi/new-site.
        You need latest kusanagi-nginx121 for lamp.
        Run ‘dnf upgrade kusanagi-nginx121’ first.
        kusanagi provision: error: command returned 1
        kusanagi provision: error: provision failed

        KUSANAGI Version 9.3.3-1.el8
        conoha

        *** (active) nginx : nginx121 ***
        * nginx.service – The NGINX HTTP and reverse proxy server
        Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled; vendor preset: disabled)
        Active: active (running) since Mon 2023-08-14 10:33:33 JST; 11min ago

        *** (inactive) httpd : httpd ***
        * httpd.service – The Apache HTTP Server
        Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
        Active: inactive (dead)

        *** (active) php : php81 ***
        * php-fpm.service – The PHP FastCGI Process Manager
        Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled; vendor preset: disabled)
        Active: active (running) since Wed 2023-08-02 12:11:27 JST; 1 weeks 4 days ago

        *** (active) mariadb : mariadb10.5 ***
        * mariadb.service – MariaDB 10.5.21 database server
        Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
        Active: active (running) since Wed 2023-08-02 12:11:28 JST; 1 weeks 4 days ago

        *** (inactive) psql : ***

        *** (inactive) pgpool-II : ***

        *** python ***
        Python 3.9.17

        *** ruby ***
        ruby is not installed.

        *** Cache status ***

        *** WAF ***
        off

        *** SELinux ***
        off

        • This topic was modified 6 months, 1 week ago by Htoyoda.
      • #1242
        cloudy
        Participant

          Htoyoda さん、こんにちは。

          nginx 1.2.1 はサポート対象外となりました。

          https://kusanagi.tokyo/releases/7989/

          kusanagi nginx --use コマンドで、
          nginx 1.2.2 〜 1.2.5 を使うよう変更してみてください。

          KUSANAGI9 コマンド

        • #1243
          cloudy
          Participant

            バージョン表記に間違いがあったので訂正します。

            – nginx 1.2.1 → nginx 1.21
            – nginx 1.2.2 → nginx 1.22
            – nginx 1.2.5 → nginx 1.25

          • #1246
            Htoyoda
            Participant

              ご回答、ありがとうございます。
              nginx1.25にアップデートして解決しました。

          Viewing 3 reply threads
          • You must be logged in to reply to this topic.

          Next article

          フォーラムについて