Vagrantfileでsynced_folderを指定するとSSHログインできなくなる

TOP Forums その他(Everything else KUSANAGI) Vagrantfileでsynced_folderを指定するとSSHログインできなくなる

Vagrantfileでsynced_folderを指定するとSSHログインできなくなる

Tagged: 

Viewing 1 reply thread
  • Author
    Posts
    • #431
      Ogaaaan
      Participant

        KUSANAGI for Vagrant


        こちらの手順通りにおこないました。

        初回はVagrantfileは一切弄らずログイン成功。
        次に、上記手順の通りにVagrantfile編集してもログイン成功。

        しかし、共有フォルダを指定しようとして、
        config.vm.synced_folder “www”, “/var”
        を指定した所、
        ssh_exchange_identification: Connection closed by remote host
        と表示されてSSHログイン失敗。

        ローカル側にはwwwフォルダはありますし、vagrant upで起動自体は問題なくできています。

        共有フォルダの指定をする場合はどうすればいいのでしょうか。

        自分がCentOS7のvmでよくやってるパターンですと、以下のような感じです。

        
          config.vm.synced_folder "www", "/var",
            :disabled => false,
            :create => true,
            :id => 'vagrant_share',
            :nfs => false,
            :owner => 'vagrant',
            :group => 'vagrant',
            :mount_options => ["dmode=777,fmode=755"]
        

        よろしくおねがいします

      • #432
        Ogaaaan
        Participant

          こちらVagrantfileの記述ミスで起きた現象でした。
          自己解決しました。

          config.vm.synced_folder "www", "/var",
          は正しくは
          config.vm.synced_folder "www", "/var/www",
          でした。

          リモート側の/varをローカルのwwwで書き換えてしまっていたようです。

          お騒がせしました。

          • This reply was modified 5 years, 10 months ago by Ogaaaan.
      Viewing 1 reply thread
      • You must be logged in to reply to this topic.

      Next article

      フォーラムについて