TOP Forums WEXAL® パーソナルライセンス WEXALでBrowser表示できないテーマ

This topic contains 5 replies, has 2 voices, and was last updated by  yasui3 4 months, 2 weeks ago.

  • Author
    Posts
  • #630

    yasui3
    Participant

    お久しぶりです。

    KUSANAGIで運用しているサイト:https://xn--cck0bd5b7b8a7a.com/

    WEXALのパーソナルライセンスでアップグレードしました。
    テーマは、Themify.meのUltraテーマです。

    その結果、
    Google Insightsで、パソコン
    KUSANAGI: 61だったものが、
    WEXAL: 91までアップしました。

    これはすごい!ととても喜んでいたら、
    友人からサイトがちゃんと見れなくなったと、レポートされました。

    確かに、
    Fireboxでは表示されません。
    Windows10 Edge(chrome版)やChromeでは、一番最初にアクセスしたときは表示されず。
    リロードしたり二度目のアクセスでは一瞬CSSが効いていない画面が表示されたあとに正常表示されます。

    テーマのサポートに問い合わせたら、
    wexal_page_speed_technology_for_wp.php
    を停止しろと、指示されました。

    私の感覚では、WEXALがBrowserからの応答を待たずに(ack確認)、次データを送信しているような動作に感じます。
    KUSANAGIでは、ちゃんと動作していますから。

    これからもWEXALを使い続けたいのですが、インフラよりも使い勝手を優先しますので、どちらか選ぶような状況に追い込まれたら、テーマの方を選択します。

    なんとか、WEXALを修正できないでしょうか?

    ちなみに、WEXALにアップグレードしたままで、
    pst offに設定しても動作は変わりません。
    pst offでキャッシュをoffにしても同じでした。後がない。
    つまり、WEXALのアンインストールが次の対応ですが、したくない…

  • #632

    hideishi
    Participant

    しっかりと見られていませんが、Themify.meの中にengagement delayしてはいけないスクリプトがあるのだと思います。
    何度もリロードするとengagementが上がるので、スクリプトがdelayされなくなり、結果的に想定通りに動作したのでしょう。
    WEXAL managerで高速化戦略モードをリソースヒントに切り替えて、Themify.meのスクリプトをengagement delayの適用から外してみてはどうでしょうか。

  • #633

    hideishi
    Participant

    あと、pst offにすればWEXALにする前の状態と同じように動作するはずです。

  • #634

    yasui3
    Participant

    hideishiさん

    確かに、pst offではこの問題は起こりません。
    確かめました。

  • #635

    yasui3
    Participant

    hideishiさん

    Themify側に問い合わせるために、engagement delayの部分(luaディレクティブ (v2.2.0-対応))の
    英語はないでしょうか? もしくは、

    そして、engagement delayは、wordpress(or nbinx,php?)の通信規約に基づいてサービスされていると思うので、
    themify側が規約を無視していると想像できるのですが、

    その規約を守れ!と改善要求をthemifyに出したいのです。

    そのためのキーワードを教えていただけませんか?

    themifyが、「改善しないorできない」と回答したら
    「Themify.meのスクリプトをengagement delayの適用から外す」ことを試したいと思います。
    また、上記キーワードがあれば、どのスクリプトを対象とすればよいか、あちら側と話が通じやすいと思います。

    せっかくベストな環境になりそうなので、ベストを目指します。

  • #643

    yasui3
    Participant

    2020.7/8に提供されたKUSANAGIの
    nginx 1.19.1
    を本日アップデートいたしました。

    アップデートだけでは改善しなかったのですが、
    # cd プロファイルのパス
    # pst init
    を実施したら、
    状況が改善し、Firefoxでのページ表示ができるようになりました。

    Q1. 私のインシデントに対応されたということでしょうか?
    Q2. もしそうならば、nginx 1.19.1のどの部分を改善されたのでしょうか?
      キーワードを教えて下さい。

    追伸:
    まだテーマ側の処理がうまく行っていない部分があるようです。
    うまく行っていない部分は、ページのアニメーションの部分です。目で見てわかります。
    (bounce in 等)
    このテーマは、Apache/2.4.43
    ではなんの問題もなく表示されます。

You must be logged in to reply to this topic.