yum updateに失敗する - –enablerepo=remiでもだめ

TOP Forums インストール(Installing KUSANAGI) yum updateに失敗する - –enablerepo=remiでもだめ

yum updateに失敗する - –enablerepo=remiでもだめ

Viewing 7 reply threads
  • Author
    Posts
    • #799
      bigjo
      Participant

      お世話になっております。
      ご教授頂けますと幸いです。何卒よろしくお願いいたします。

      kusanagi 8.5.9-7
      PHP7-7.4.20
      nginx 1.21.0

      表題の通り、yum updateをしても失敗してしまいます。

      ■エラー内容
      Error: Package: kusanagi-php7-7.4.26-1.noarch (kusanagi)
      Requires: libicudata.so.69()(64bit)
      Error: Package: kusanagi-php7-7.4.26-1.noarch (kusanagi) libicui18n.so.69() (64bit)
      Requires: Error: Package: kusanagi-php7-7.4.26-1.noarch (kusanagi)
      Requires: libicuuc.so.69()(64bit)
      Error: Package: kusanagi-php7-7.4.26-1.noarch (kusanagi)
      Requires: libicuio.so.69()(64bit)

      You could try using --skip-broken to work around the problem
      You could try running: rpm -Ua --nofiles --nodigest

      ■実施したこと

      ・yum clean allの実施後にyum update実施
      → エラー内容変わらず、失敗。

      ・yum update –enablerepo=remi
      → バージョンを確認してもアップデート失敗。(以下はyum update –enablerepo=remi
      実行ロゴ)

      Available: kusanagi-php?-7.2.3-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php?-7.2.4-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php?-7.2.5-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php7-7.2.6-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php7-7.2.6-2.noarch (kusanagi)
      Not found
      Available: kusanagi-php7-7.2.7-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php?-7.2.8-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php?-7.2.8-2.noarch (kusanagi)
      Not found
      Available: kusanagi-php7-7.2.9-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php?-7.2.18-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php7-7.2.11-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php?-7.2.11-2.noarch (kusanagi)
      Not found
      Available: kusanagi-php7-7.2.12-1.noarch (kusanagi)
      Not found
      Available: kusanagi-php7-7.3.8-1.noarch (kusanagi)
      Not found

      You could try using --skip-broken to work around the problem
      You could try running: rpm -Ua --nofiles --nodigest

      ・dnf update
      →KUSANAGI公式ページにバージョンのアップデートのコマンドがあったので試してみましたが、コマンドが使えませんでした。

      早急に対処したい次第です。
      お忙しいところ恐縮ですが、ご対応宜しくお願い致します。

    • #800
      cloudy
      Participant

      bigjo さん、こんばんは。

      yum update --enablerepo=remi はハイフンが2つです。

      詳しくは下記更新記事をご確認ください。

      KUSANAGIモジュール更新情報

    • #801
      bigjo2
      Participant

      ご回答いただきありがとうございます。
      アカウントが開けなくなってしまったため、違うアカウントからご返事しております。

      こちら僕の記載ミスで、実際には yum update --enablerepo=remi で記載しており、

      You could try using –skip-broken to work around the problem
      You could try running: rpm -Ua –nofiles –nodigest

      となり、バージョンを確認してもアップデートさせておりません。

      記載いただいたWebページを確認いたしましたが、こちらに記載の方法も試してみました。
      お手数をおかけして失礼いたしますが、何卒よろしくお願いいたします。

    • #802
      cloudy
      Participant

      bigjo さん、こんばんは。

      ログは正常なログの最終行から、異常が発生した部分をすべてコピペしてください。
      上記内容では、失敗していることはわかるのですが、原因が全くわかりません。

      ここからはもう予想になりますので、とりあえず試していただきたい内容です。

      1. アップデート

      FAQの内容 https://kusanagi.tokyo/faq/
      Q6. yum のアップデートに失敗する場合は、どのように対応すればよろしいですか?
      より

      yum clean all
      yum update --enablerepo=remi,remi-php56

      上記を試していただいてもよろしいでしょうか?
      なお、FAQへのリンクはトップページに記載してあります。

      2. 現在の環境

      詳細に教えていただけますか?

      kusanagi status

      一部ドメイン名などが表示されますので、マスク処理をお願いします。
      なお、質問する際に記載してほしい情報として、コマンド例がトップページに記載してあります。

    • #822
      bigjo2
      Participant

      cloudy様、ご回答いただきありがとうございます。
      情報に不備があり申し訳ございません。

      以下2点回答させていただきます。
      何卒よろしくお願いいたします。

      1.アップデート

      頂いたFAQを参考に以下のコードを試したところアップデートは終了したのですが、バージョンは変わりませんでした。(外部サイト:Twitter

      yum clean all
      yum update --enablerepo=remi,remi-php56

      その後、以下も試してみましたが変化なしです。

      yum clean all
      yum --enablerepo=remi,remi-php56 update -y
      yum clean all
      yum update -y kusanagi
      yum clean all
      yum --enablerepo=remi,remi-php56 update -y kusanagi-php7

      2.現在の環境
      以下3つのコードのキャプチャです。(外部サイト:Twitter

      kusanagi status
      kusanagi --version
      yum check-update

      お手数をおかけして大変恐縮ですが、何卒よろしくお願いいたします。

    • #825
      cloudy
      Participant

      bigjo さん、こんにちは。

      返信頂いてたみたいですが、投稿が反映されていなかったようです。
      反映していただきましたので、確認が遅くなりました。申し訳ないです。

      頂いたFAQを参考に以下のコードを試したところアップデートは終了したのですが、バージョンは変わりませんでした。(外部サイト:Twitter)

      それでいいのではないでしょうか??
      アップデートがないということなので、解決していると思いますけれども。。。?

      もともとの問題は、

      yum update --enablerepo=remi

      でエラーが出るということですよね?
      もう一度試してもらっても良いでしょうか?
      たぶん、エラーは出ないと思います。

      エラーが出た場合は、改めて下記を試してください。

      yum clean all
      yum update kusanagi -y
      yum update --enablerepo=remi,remi-php56 -y

      そして改めて確認として

      yum update --enablerepo=remi

      これでエラーが出た場合は、すべての出力をこちらに貼り付けてください。

      よろしくお願いいたします。

    • #826
      cloudy
      Participant

      bigjo さん、こんにちは。

      投稿が反映されていなかった件ですが、許可していないタグを使用されていたため、スパム判定されていたようです。

      タグを使用される際は、許可されているタグ(投稿ボックス上部のバーにあるタグ)以外の使用はお控えください。

    • #833
      cloudy
      Participant

      bigjo さん、こんにちは。

      追記です。

      頂いたFAQを参考に以下のコードを試したところアップデートは終了したのですが、バージョンは変わりませんでした。(外部サイト:Twitter)

      (もしかしてですが)問題点が変わっていますか?

      当初の問題は『アップデートできない』だったので解決したと思っています。
      改めて回答を読むと、『バージョンは変わりませんでした。』となっています。

      もし、問題点が別に変わったのであれば、解決した点と別の問題点が発生したということを記載していただけますと助かります。

      そもそも今回のゴールはなんでしょう?なんのバージョンが変わればいいのでしょうか?
      バージョンはどのバージョンの話でしょうか? KUSANAGI ですか? PHP ですか? Nginx ですか?
      メジャーバージョンですか?マイナーバージョンですか?リビジョンですか?なっていてほしいバージョンと現在のバージョンは何でしょう?
      どのように確認したときの話でしょうか?コマンドですか?ログですか?設定ファイルですか?クライアントからですか?

      ここから予想です。

      PHP や Nginx のアップデートはうまくできたので解決しました。
      ただ新たな問題が発生しました。アップデートした Nginx のバージョンを nginx -v で確認したところ、リビジョンが古いバージョン 1.21.3 のままで、1.21.4 になっていません。

      上記の質問の意味ですと、Nginx の再起動が必要です。
      一番手っ取り早いのは、サーバーの再起動ですが、コマンドで各モジュールごとの再起動も可能です。

      Nginx 再起動
      kusanagi nginx

      PHP7 再起動
      kusanagi php7

      (参考) KUSANAGIモジュール更新情報

      KUSANAGIモジュール更新情報

Viewing 7 reply threads
  • You must be logged in to reply to this topic.

Next article

フォーラムについて